[Solved] language package issue

Hello, I've been trying to do this for hours but to no avail... I need help...

I'd like to activate the French language package as default package for Newsletter. I have downloaded the fr-FR.mo language package from the suggested site and I have followed the instructions, but to no avail...

My wp default language is French (overall on my site)

Now, following a suggestion on a post on this forum, I renamed the newsletter directory on my server to wp-mailinglist

After I created a directory called : wp-mailinglist-languages

Inside I uploaded the fr_FR.mo file, I even put the fr_FR.po just in case...

After, I've updated to permission of the .mo and .po files to 0755.

AND now, the French language package seems to be recognize by Newsletter, however the extension stays in English and the page where to manage the subscription is also in English...

I'm using WPML for my multilingual site...



wp 4.4.1 and the latest version od newsetter (which I downloaded a few hours ago)

I don't know what to try anymore... I'm a bit lost becuse I'm a newbie...

Thanks for your help

 

Pat

Comments

  • 13 Comments sorted by
  • Vote Up0Vote Down

    @infinityunit

    I will assist you with the language issue in the Newsletter plugin.

    How did download the language file? Did you right-click, download?

    We see many users doing this and that Github repository gives an HTML file instead.

    Please download the entire ZIP file: https://github.com/TribulantSoftware/wp-mailinglist-languages/archive/master.zip . And then get the wp-mailinglist-fr_FR.mo file inside the package. 

    Then put that wp-mailinglist-fr_FR.mo file into wp-content/plugins/wp-mailinglist-languages/ .

    Also go to Newsletters > Configuration > System and tick the checkbox for load external language. That way you're hosting the language file outside of the plugin.

    Which extension is staying in English?

  • Vote Up0Vote Down

    Hello tribulant, many thanks for your answer. Indeed i downloaded using the right button. Will try what you instructed and see if it works. Will get back to you in a few hours :-) thanks again

     

     

     

     

     

  • Vote Up0Vote Down

    @inifinityunit

    Great, thank you for the follow-up.

    If you download the package and get the file from that and do it that way, it should resolve the problem.

    Please post back once you've checked then we can mark this as [Solved] once it is resolved.

  • Vote Up0Vote Down

    Hello tribulant, it worked. However before it did,

    I had to change the names back to what they were. That is rename the directory to "newsletter-lite" and rename the language file to "newsletter-lite-fr_FR.mo".

    After doing that, it worked well. I would go ahead and call this one solved!

    Thanks

    Pat

  • Vote Up0Vote Down

    Hey Tribulant, one last thing please, there seems to be a missing string in the translation. When confirming the subscription, The page where the users get redirected from the confirmation email, will be in french, except for the title : MANAGE SUBSCRIPTIONS.

    I've opened the .po file with poedit and was able to identified this title, and it seemed to be correctly translated however, I wonder if it is the exact same string... Can you check that, please? I would very much like to have a fully working translation...

    Many thanks

     

    Pat

  • Vote Up0Vote Down

    Hello Tribulant,

     

    I think I was a little rash in asking. I found the page that needed to be translated in pages in the dashboard...

    So I guess I'm good to go for another while before more questions arise.

     

    Thanks

     

    Pat

  • Vote Up0Vote Down

    @infinityunit

    Thank you for your responses.

    Parts of the Manage Subscriptions page of the Newsletter plugin is in the language file. Some other things can be translated under Newsletters > Configuration accordingly.

    I'm glad to hear that you found it though.

  • Vote Up0Vote Down
    I still have the problem that the Manage Subscriptions Page is not displayed in german language. It's still english.

    I have downloaded the wp-mailinglist-languages-master ZIP-file and uploaded the german .mo file via ftp: wp-content/languages/plugins/wp-mailinglist-de_DE.mo

    In the System Configuration/System/ Wordpress Related the de_DE.mo file is set as current language. Do you have an idea? Thanks!
  • Vote Up0Vote Down
    @"Hey Horst"

    If you are using qTranslate-X or WPML for multilingual on your website, you need to create 2 Manage Subscriptions pages.

    Go to Pages in WordPress and create another Manage Subscriptions page for the other language.

    Once you've done that, go to Newsletters > Configuration > Subscribers > Subscriber Management and you'll see that you can fill in the page ID of the Manage Subscriptions page in each language accordingly.

    That should resolve the problem, please let me know.
  • Vote Up0Vote Down
    edited January 11
    Sorry, it doesn't work. The Manage Subscription-Site is still displayed in english language.

    1. Its only a "One Language"-Site: German

    I have...
    - created a second Manage Subscriptions page and filled in the new ID (shortcode: [newsletters_management] )
    - uploaded the de_DE.mo file also in the plugin languages folder and tested (ftp permission 644, 755, 777)
    - the wp-config.php contains define( 'WPLANG', 'de_DE' );

    In the languages ReadMe.md is written: 5. Go to Newsletters > Configuration > System > WordPress Related in the plugin and tick/check "Yes, load external language file" for the "Load External Language" setting.

    I cant find that checkbox?!
  • Vote Up0Vote Down
    ... I tried the ftp permission also in 755, 777..
  • Vote Up0Vote Down
    @"Hey Horst"

    What is the folder name of the plugin under wp-content/plugins/ ?

    If it is newsletters-lite, please rename it to wp-mailinglist
    Then go to Plugins in WordPress and reactivate the plugin.

    The rename of the plugin's folder name should ensure the language file is loaded. It is an issue with the textdomain which we will release an update for shortly.

    I look forward to your response once you've tried it out.
  • Vote Up0Vote Down
    Hello tribulant,
    I have renamed the folder and reactivated the plugin.
    It works now!!

    Thanks a lot!
  • Vote Up0Vote Down
    @"Hey Horst"

    I'm glad to hear that renaming the folder to wp-mailinglist solved the problem.
Sign In or Register to comment.