[Solved] Export delimiter default should not be semi-colon

edited August 2015 in Newsletter plugin

I think the title says it all. It's COMMA-separated-values in CSV. Defaulting to semi-colon produces files that Excel cannot automatically convert to columns. That could be lived with and the delimiter changed to a comma (after always forgetting the first time), but downloads from other places such as the list of mails sent for a newsletter are defaulting to this without any option.

I can understand making the delimter optional, but I don't see why not to use the industry standard comma. Free form text fields should be wrapped in speech marks anyway, so it shouldn't be a problem with commas in fields.



  • 2 Comments sorted by
  • Vote Up0Vote Down


    Thank you for your post.

    Yes, you're right, CSV stands for Comma Separated Values.

    Unfortunately even with that, the majority of spreadsheet software uses semi-colon for some reason.

    You can set the delimiter to export with in the Newsletter plugin though.

    We'll add this setting to the other sections asap or at least provide a global setting for this in the plugin.

    Sorry for any inconvenience caused by this.

  • Vote Up0Vote Down


    We have added a feature to the latest development of our Newsletter plugin under Newsletters > Configuration > System to configure a global CSV delimiter for imports/exports accordingly.

    This release will be made shortly with this feature included.

Sign In or Register to comment.