Thumbnails not showing (not being the path issue)


I've just installed this plugin and am trying it out on a testing site, before setting it up for my portfolio site.

Theme: Twenty Fourteen (with extended plugin)
WP Version: 3.8.1
Slideshow Gallery version:

Here's the thing:
The screenshots are loading correctly, both when I use the link to the media file and when I upload it. BUT..... the thumbnails are broken. I've tested it and I get the following message:

A TimThumb error has occured

The following error(s) occured:
  • Could not create the file cache directory.
String :
TimThumb version : 2.8.10

Weird thing is.... The cache directoy is exactly where it should be (in the folder: public_html/wp-content/uploads/sites/3/slideshow-gallery) with permission 777.

Now, the possibility of the thumbnails in the slideshow is exactly what made this plugin so interesting, so I really want to get that to work. So, how can I solve this?
I've already checked if all the folders have the permission and they're all set to 777 which should be more than sufficient.
I've checked to see if I could find any thumbnails in the folders, but there aren't any. The uploaded screenshots are there, though.

Oh, and I've got WP3.8.1 installed with the Theme Twenty Fourteen.
I've also installed and activated the plugin Twenty Fourteen Extended. This didn't change anything in the gallery. Thought I should mention that.

I've tried a different path through the image tester, but that didn't work. I get the same message.

And just to be complete, here's a link to the post.

Thanks for the help.



  • 5 Comments sorted by
  • Vote Up0Vote Down

    Thank you for your post.

    The TimThumb error "Could not create the cache file directory" means that the cache is inaccessible.

    Please go to "wp-content/uploads/slideshow-gallery/cache/" and ensure the "cache" folder exists and that it is writable 0777. Then there should also be a new, blank index.html file in there which should also be writable.

    The TimThumb file is located at "slideshow-gallery/vendors/timthumb.php" in the Slideshow Gallery plugin.
  • Vote Up0Vote Down
    Okay, I think I've found the problem. I've got WP installed as a network which has two sites:
    - Fantasygamecreations (my future portfolio)
    - Testingblog1 (everything for testing before installing it on my future portfolio

    timthumb.php thinks the cache is in:
    FILE_CACHE_DIRECTORY', '../../../uploads/slideshow-gallery/cache

    While my filemanager shows NO cache directory in my upload directory for the testingblog1. All files are uploaded in:

    I assume if I change this line in the timthumb.php it will be valid for ALL sites, including my portfolio site, which actually has:

    I do want to keep the two sites separated for obvious reasons. I really don't want any testing on my portfolio site :)

    Thanks again for the help.

    BTW, like i said earlier, uploads and everything in it has 777 as permissions set.
  • Vote Up0Vote Down
    Thank you for your response.

    We've added this to our development list so that we can change the TimThumb cache path to work correctly with WordPress multi-site as you've mentioned.

    We are currently working on an update which will be available shortly.
  • Vote Up0Vote Down
    @tribulant Do you happen to have a time from on "shortly"? Just so that I know if I have to temporary use the WP default gallery (which isn't to my liking) or if I can wait until the update before setting up my portfolio site.

    Thanks again for your help!
  • Vote Up0Vote Down
    Is there any news on this? In the change logs with the latest update I didn't see anything relating to this particular issue.
Sign In or Register to comment.