Plugin breaks next/previous post in 2014 theme

Hey all,

I'm using the default theme for WP: 2014. I already have other problems with the plugin, but now I figured another problem:
My 10th post (Gallery test 9) shows for next post it's own post,
while there three more (Gallery test 10, gallery test 11 and then
another more recent post). For previous post it shows Gallery test 7,
while it should show Gallery test 8

All the other posts are functioning completely normal. I've checked
each and every post (lucky I've only made 10 or so posts so far!)

I've checked all the plugins, because originally I thought there was a different cause for the problem and I posted the problem on the site.

Right now I have disabled this plugin but I really want to have it functioning. I've got the following plugins installed and functioning properly:
1. Akismet (result okay)

2. Jetpack (with extra settings enabled) (result okay)

3. Limit Login Attempts (result okay)

4. Fourteen Extended (result okay)

5. Styles (result okay)

6. Styles: TwentyFourteen (result okay)

7. TinyMCE Advanced (result okay)

When I activate the slideshow gallery, I get the problem. So... how do I solve that?

ETA: FYI, I've tested to see if the style plugins were a problem, but when I deactivate the plugins from step 5 and 6 and reactivate the slideshow plugin I continue to have the problem.
I've also deactivated Fourteen extended and reactivated Slideshow, but it still breaks the system.
I've deactivated a few Jetpack modules one at a time to see if there was anything in there that migth have a conflict:
Module "Related posts" and reactivated Slideshow, still the same result.
Module "likes" and reactivated Slideshow, same result.
I've deactivated the Jetpack module and reactivated the Slideshow, still the same result. Only active plugins at this point were: Akismet, TinyMCE Advanced and Limit Slogin Attempts beside the Slideshow.
Then I decided to deactivate everything and then only reactivate the slide show. So basically this was a clean install of WP with ONLY the slideshow activated. Unfonrtunately, this breaks the system too!

So.... the slideshow plugin seems to have a bug that causes the default WP system (clean install with 2014 theme, not customized) to break.

Plugin version is: Version

I'll deactivate the plugin for now, cause I don't want a site that's breaking due to this plugin. It would be good, though if this would be fixed ASAP.


  • 3 Comments sorted by
  • Vote Up0Vote Down
    ETA: I thought it might be handy to include a screenshot of what I mean, since I've deactivated the plugin on my site.

    As you can see in the title and adresbar I'm already in the post Gallery Test 9. However, the previous post says Gallery test 7, while you can see in recent posts, there is a Gallery test 8 before 9 instead.
    And somehow the next post is.... Gallery test 9, both in title and in address as you can see in the bottom of the screenshot. I hovered my mouse over the title of the next post. Of course the post itself can never be also the next post.
  • Vote Up0Vote Down
    Okay, I've run Firebug debugger in Firefox and I found the following:
    I've tested it with another default theme (2013) and I had exactly the same problem. So...... Apparently it's a plugin problem.

    The Pluging breaks the link rel=prev & link rel=next in the actual page.

    I've been looking into it a little bit more and here's what I find:

    In the head of the page the link rel are perfect:

    <link rel='prev' title='Gallery test 10' href='' />
    <link rel='next' title='test om te zien hoe de permalink uitvalt.' href='' />

    They're exactly what they should be. However, when they're displayed on the page they give:

    Previous Post

    Hello world!

    Next Post

    Gallery test 2

    And I find the following code in the debug screen of Firebug debugger:

    <nav class="navigation post-navigation" role="navigation">
    <h1 class="screen-reader-text">Post navigation</h1>
    <div class="nav-links">
    <a href=""; rel="prev"><span class="meta-nav">Previous Post</span>Hello world!</a><a href=""; rel="next"><span class="meta-nav">Next Post</span>Gallery test 2</a> </div><!-- .nav-links -->
    </nav><!-- .navigation -->

    So... It appears somehow Slideshow Gallery messes with the post navigation once the header.php has been loaded.

    Of course this is absolutely NOT good.

    Is there anyone who's got any idea what the heck is going on? I'm also starting to wonder if Tribulant people are... all on a holiday perhaps?

  • Vote Up0Vote Down
    Okay, I've seen no one from Tribulant has been answering any of the posts here on the Slideshow forum for at least the last two weeks and I don't think I've seen any answers from Tribulant on any of the other forums either.... So, I decided to dig deeper into this problem and I found something which is kinda.... disturbing, I guess:

    As it turns out, there's one particular problem:

    If you use pictures from another post, the previous/next links break!!!

    So.... Here's a clear warning:

    Do NOT use pictures from another post. That screws up your post navigation.

    I figured this out when I decided to directly add images to my
    default WP library instead of through the post. When I tried to do this
    through my post the plugin says there are no slides available (the post
    actually shows the pictures I included in the post, go figure!).

    So... how do you get this thing to work? Like this:

    1. Make a post and save it as a draft.

    2. Add your images directly to your WP library

    3. Attach your images to your saved draft (an overview of your posts will show up when you click attach in the library)

    4. Use the code: [tribulant_slideshow post_id="x"] Where x is the id of your saved draft (NOT another post!!!!).

    5. Now publish your post.

    So.... for me this is resolved now, but of course this is not how it
    should function. It's rediculous! I hope someone else with a similar
    problem finds this solution helpful.

    And of course I hope Tribulant will find a final solution for this problem.

    And maybe there can be an added option in the pop-up screen from the slideshow gallery button in the aditor:
    * Use images from this post

    After all, when you start writing your post, there's no id yet. The ID becomes available when you save your draft.
Sign In or Register to comment.